What’s Vulnerable › Vulnerabilities
CVE-2016-2141
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-06-30 · updated 2026-06-17
Description
It was found that JGroups did not require necessary headers for encrypt and auth protocols from new nodes joining the cluster. An attacker could use this flaw to bypass security restrictions, and use this vulnerability to send and receive messages within the cluster, leading to information disclosure, message spoofing, or further possible attacks.
Affected products
- Red Hat JBoss EAP: 5.2, 6.4, 7.0
- RedHat Jgroups: before 4.0 — fixed in 4.0
How to fix
Upgrade to a fixed version: RedHat Jgroups 4.0. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2016-1435.html
- http://rhn.redhat.com/errata/RHSA-2016-1439.html
- http://rhn.redhat.com/errata/RHSA-2016-2035.html
- http://www.securityfocus.com/bid/91481
- http://www.securitytracker.com/id/1036165
- https://access.redhat.com/errata/RHSA-2016:1345
- https://access.redhat.com/errata/RHSA-2016:1346
- https://access.redhat.com/errata/RHSA-2016:1347
- https://access.redhat.com/errata/RHSA-2016:1374
- https://access.redhat.com/errata/RHSA-2016:1376
- https://access.redhat.com/errata/RHSA-2016:1389
- https://access.redhat.com/errata/RHSA-2016:1432
Get alerted when CVE-2016-2141 or the next vulnerability affects your stack