What’s Vulnerable › Vulnerabilities
CVE-2016-2143
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-04-27 · updated 2026-06-17
- Weakness: CWE-20
Description
The fork implementation in the Linux kernel before 4.5 on s390 platforms mishandles the case of four page-table levels, which allows local users to cause a denial of service (system crash) or possibly have unspecified other impact via a crafted application, related to arch/s390/include/asm/mmu_context.h and arch/s390/include/asm/pgalloc.h.
Affected products
- Debian Linux: 6.0, 7.0, 8.0
- Linux kernel: from 2.6.25 before 3.2.79; from 3.3 before 3.12.58; from 3.13 before 3.16.35; from 3.17 before 4.1.21; from 4.2 before 4.4.6 — fixed in 3.12.58, 3.16.35, 3.2.79, 4.1.21, 4.4.6
- Oracle Corporation Oracle Linux: 7-0
- Red Hat Enterprise Linux: 7.0
How to fix
Upgrade to a fixed version: Linux kernel 3.12.58, 3.16.35, 3.2.79, 4.1.21. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=3446c13b268af86391d06611327006b059b8bab1
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00019.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00052.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00054.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00059.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00038.html
- http://rhn.redhat.com/errata/RHSA-2016-1539.html
- http://rhn.redhat.com/errata/RHSA-2016-2766.html
- http://www.debian.org/security/2016/dsa-3607
- http://www.oracle.com/technetwork/topics/security/linuxbulletinjul2016-3090544.html
- https://github.com/torvalds/linux/commit/3446c13b268af86391d06611327006b059b8bab1
Get alerted when CVE-2016-2143 or the next vulnerability affects your stack