What’s Vulnerable › Vulnerabilities
CVE-2016-2173
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-04-21 · updated 2026-06-17
- Weakness: CWE-20
Description
org.springframework.core.serializer.DefaultDeserializer in Spring AMQP before 1.5.5 allows remote attackers to execute arbitrary code.
Affected products
- Fedoraproject Fedora: 22, 23, 24
- Spring AMQP: before 1.5.5 — fixed in 1.5.5
How to fix
Upgrade to a fixed version: Spring AMQP 1.5.5. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182551.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182850.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182959.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1326205
- https://pivotal.io/security/cve-2016-2173
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182551.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182850.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/182959.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1326205
- https://pivotal.io/security/cve-2016-2173
Get alerted when CVE-2016-2173 or the next vulnerability affects your stack