What’s Vulnerable › Vulnerabilities
CVE-2016-2178
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-06-20 · updated 2026-06-17
- Weakness: CWE-203
Description
The dsa_sign_setup function in crypto/dsa/dsa_ossl.c in OpenSSL through 1.0.2h does not properly ensure the use of constant-time operations, which makes it easier for local users to discover a DSA private key via a timing side-channel attack.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04
- Debian Linux: 8.0
- Node.js: from 0.10.0 before 0.10.47; from 0.12.0 before 0.12.16; from 4.0.0 through 4.1.2; from 4.2.0 before 4.6.0; from 5.0.0 before 6.7.0 — fixed in 0.10.47, 0.12.16, 4.6.0, 6.7.0
- OpenSSL: 1.0.1, 1.0.1a, 1.0.1b, 1.0.1c, 1.0.1d, 1.0.1e (+24)
- Oracle Corporation Oracle Linux: 5, 6, 7
- Oracle Corporation Solaris Operating System: 10, 11.3
- SUSE Linux Enterprise: 12.0
How to fix
Upgrade to a fixed version: Node.js 0.10.47, 0.12.16, 4.6.0, 6.7.0. Check the vendor advisory for mitigations.
References
- http://eprint.iacr.org/2016/594.pdf
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10759
- http://lists.opensuse.org/opensuse-security-announce/2016-09/msg00022.html
- http://lists.opensuse.org/opensuse-security-announce/2016-09/msg00023.html
- http://lists.opensuse.org/opensuse-security-announce/2016-09/msg00024.html
- http://lists.opensuse.org/opensuse-security-announce/2016-09/msg00031.html
- http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00013.html
- http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00029.html
Get alerted when CVE-2016-2178 or the next vulnerability affects your stack