What’s Vulnerable › Vulnerabilities
CVE-2016-2183
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 94.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-09-01 · updated 2026-06-17
- Weakness: CWE-200
Description
The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other protocols and products, have a birthday bound of approximately four billion blocks, which makes it easier for remote attackers to obtain cleartext data via a birthday attack against a long-duration encrypted session, as demonstrated by an HTTPS session using Triple DES in CBC mode, aka a "Sweet32" attack.
Affected products
- Cisco Content Security Management Appliance (SMA): 9.6.6-068, 9.7.0-006
- Node.js: from 0.10.0 before 0.10.47; from 0.12.0 before 0.12.16; from 4.0.0 before 4.1.2; from 4.2.0 before 4.6.0; from 6.0.0 before 6.7.0 — fixed in 0.10.47, 0.12.16, 4.1.2, 4.6.0, 6.7.0
- OpenSSL: 1.0.1a, 1.0.1b, 1.0.1c, 1.0.1d, 1.0.1e, 1.0.1f (+20)
- Oracle Database: 11.2.0.4, 12.1.0.2
- Python: from 2.7.0 before 2.7.13; from 3.4.0 before 3.4.7; from 3.5.0 before 3.5.3 — fixed in 2.7.13, 3.4.7, 3.5.3
- Red Hat Enterprise Linux: 5.0, 6.0, 7.0
- Red Hat JBoss EAP: 6.0.0
- Red Hat JBoss Enterprise Web Server: 1.0.0, 2.0.0
- RedHat Jboss Web Server: 3.0
How to fix
Upgrade to a fixed version: Node.js 0.10.47, 0.12.16, 4.1.2, 4.6.0; Python 2.7.13, 3.4.7, 3.5.3. Check the vendor advisory for mitigations.
References
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10759
- http://lists.opensuse.org/opensuse-security-announce/2016-09/msg00022.html
- http://lists.opensuse.org/opensuse-security-announce/2016-09/msg00023.html
- http://lists.opensuse.org/opensuse-security-announce/2016-09/msg00024.html
- http://lists.opensuse.org/opensuse-security-announce/2016-09/msg00031.html
- http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00013.html
- http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2016-10/msg00029.html
- http://lists.opensuse.org/opensuse-security-announce/2017-01/msg00068.html
Get alerted when CVE-2016-2183 or the next vulnerability affects your stack