What’s Vulnerable › Vulnerabilities
CVE-2016-2381
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-04-08 · updated 2026-06-17
- Weakness: CWE-20
Description
Perl might allow context-dependent attackers to bypass the taint protection mechanism in a child process via duplicate environment variables in envp.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10
- Debian Linux: 7.0, 8.0
- Opensuse: 13.2
- Oracle Corporation Communications Billing and Revenue Management: 7.5
- Oracle Corporation Configuration Manager: before 12.1.2.0.4; 12.1.2.0.6 — fixed in 12.1.2.0.4
- Oracle Database: 11.2.0.4, 12.1.0.2, 12.2.0.1, 18c, 19c
- Oracle Corporation Enterprise Manager Base Platform: 13.2.0.0.0, 13.3.0.0.0
- Oracle Corporation Solaris Operating System: 11.3
- Oracle Corporation TimesTen In-Memory Database: before 18.1.2.1.0 — fixed in 18.1.2.1.0
- perl: before 5.23.9 — fixed in 5.23.9
How to fix
Upgrade to a fixed version: Oracle Corporation Configuration Manager 12.1.2.0.4; Oracle Corporation TimesTen In-Memory Database 18.1.2.1.0; perl 5.23.9. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2016-03/msg00112.html
- http://perl5.git.perl.org/perl.git/commitdiff/ae37b791a73a9e78dedb89fb2429d2628cf58076
- http://www.debian.org/security/2016/dsa-3501
- http://www.gossamer-threads.com/lists/perl/porters/326387
- http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html
- http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html
- http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html
- http://www.securityfocus.com/bid/83802
- http://www.ubuntu.com/usn/USN-2916-1
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05240731
- https://security.gentoo.org/glsa/201701-75
- https://www.oracle.com/security-alerts/cpuapr2020.html
Get alerted when CVE-2016-2381 or the next vulnerability affects your stack