What’s Vulnerable › Vulnerabilities
CVE-2016-2782
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-04-27 · updated 2026-06-17
- Weakness: CWE-476
Description
The treo_attach function in drivers/usb/serial/visor.c in the Linux kernel before 4.5 allows physically proximate attackers to cause a denial of service (NULL pointer dereference and system crash) or possibly have unspecified other impact by inserting a USB device that lacks a (1) bulk-in or (2) interrupt-in endpoint.
Affected products
- Linux kernel: before 4.5.0; 4.5.0-rc1 — fixed in 4.5.0
- SUSE Linux Enterprise Debuginfo: 11-sp2, 11-sp4
- SUSE Linux Enterprise Server 15 SP1: 12, 12-sp1
- SUSE Linux Enterprise Module For Public Cloud: 12
- SUSE Linux Enterprise Real Time Extension: 11-sp4, 12-sp1
- SUSE Linux Enterprise Server: 11-sp2, 11-sp4, 12, 12-sp1
- SUSE Linux Enterprise Software Development Kit: 11-sp4, 12, 12-sp1
- SUSE Linux Enterprise Workstation Extension: 12, 12-sp1
How to fix
Upgrade to a fixed version: Linux kernel 4.5.0. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=cac9b50b0d75a1d50d6c056ff65c005f3224c8e0
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00019.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00052.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00054.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00059.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00038.html
- http://www.openwall.com/lists/oss-security/2016/02/28/9
- http://www.ubuntu.com/usn/USN-2929-1
- http://www.ubuntu.com/usn/USN-2929-2
- http://www.ubuntu.com/usn/USN-2930-1
- http://www.ubuntu.com/usn/USN-2930-2
Get alerted when CVE-2016-2782 or the next vulnerability affects your stack