What’s Vulnerable › Vulnerabilities

CVE-2016-2788

Description

MCollective 2.7.0 and 2.8.x before 2.8.9, as used in Puppet Enterprise, allows remote attackers to execute arbitrary code via vectors related to the mco ping command.

Affected products

How to fix

Upgrade to a fixed version: Puppet Enterprise 2016.2.1, 3.8.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-2788 or the next vulnerability affects your stack