What’s Vulnerable › Vulnerabilities
CVE-2016-3074
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 37.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-04-26 · updated 2026-06-17
- Weakness: CWE-681
Description
Integer signedness error in GD Graphics Library 2.1.1 (aka libgd or libgd2) allows remote attackers to cause a denial of service (crash) or potentially execute arbitrary code via crafted compressed gd2 data, which triggers a heap-based buffer overflow.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10, 16.04
- Debian Linux: 7.0, 8.0
- Fedoraproject Fedora: 23, 24
- Libgd: 2.1.1
- Opensuse: 13.2
- PHP: from 5.5.0 before 5.5.35; from 5.6.0 before 5.6.21; from 7.0.0 before 7.0.6 — fixed in 5.5.35, 5.6.21, 7.0.6
How to fix
Upgrade to a fixed version: PHP 5.5.35, 5.6.21, 7.0.6. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/183263.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-May/183724.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00031.html
- http://packetstormsecurity.com/files/136757/libgd-2.1.1-Signedness.html
- http://rhn.redhat.com/errata/RHSA-2016-2750.html
- http://seclists.org/fulldisclosure/2016/Apr/72
- http://www.debian.org/security/2016/dsa-3556
- http://www.debian.org/security/2016/dsa-3602
- http://www.securityfocus.com/archive/1/538160/100/0/threaded
- http://www.securityfocus.com/bid/87087
- http://www.securitytracker.com/id/1035659
- http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.383127
Get alerted when CVE-2016-3074 or the next vulnerability affects your stack