What’s Vulnerable › Vulnerabilities
CVE-2016-3078
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 56.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-08-07 · updated 2026-06-17
- Weakness: CWE-190
Description
Multiple integer overflows in php_zip.c in the zip extension in PHP before 7.0.6 allow remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted call to (1) getFromIndex or (2) getFromName in the ZipArchive class.
Affected products
- PHP: from 7.0.0 before 7.0.6 — fixed in 7.0.6
How to fix
Upgrade to a fixed version: PHP 7.0.6. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/04/28/1
- http://www.securitytracker.com/id/1035701
- https://bugs.php.net/bug.php?id=71923
- https://github.com/php/php-src/commit/3b8d4de300854b3517c7acb239b84f7726c1353c?w=1
- https://php.net/ChangeLog-7.php
- https://security-tracker.debian.org/tracker/CVE-2016-3078
- https://www.exploit-db.com/exploits/39742/
- http://www.openwall.com/lists/oss-security/2016/04/28/1
- http://www.securitytracker.com/id/1035701
- https://bugs.php.net/bug.php?id=71923
- https://github.com/php/php-src/commit/3b8d4de300854b3517c7acb239b84f7726c1353c?w=1
- https://php.net/ChangeLog-7.php
Get alerted when CVE-2016-3078 or the next vulnerability affects your stack