What’s Vulnerable › Vulnerabilities
CVE-2016-3088: Apache ActiveMQ Improper Input Validation Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-02-10
- EPSS: 98.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-06-01 · updated 2026-06-17
- Weakness: CWE-434
Description
The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote attackers to upload and execute arbitrary files via an HTTP PUT followed by an HTTP MOVE request.
Affected products
- Apache ActiveMQ: from 5.0.0 before 5.14.0 — fixed in 5.14.0
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.14.0. Check the vendor advisory for mitigations.
References
- http://activemq.apache.org/security-advisories.data/CVE-2016-3088-announcement.txt
- http://rhn.redhat.com/errata/RHSA-2016-2036.html
- http://www.securitytracker.com/id/1035951
- http://www.zerodayinitiative.com/advisories/ZDI-16-356
- http://www.zerodayinitiative.com/advisories/ZDI-16-357
- https://lists.apache.org/thread.html/a859563f05fbe7c31916b3178c2697165bd9bbf5a65d1cf62aef27d2%40%3Ccommits.activemq.apache.org%3E
- https://lists.apache.org/thread.html/f956ea38e4da2e2c1e7131e6f91e41754852f5a4861d1a14ca5ca78a%40%3Cusers.activemq.apache.org%3E
- https://lists.apache.org/thread.html/r6d03e45b81eab03580cf7f8bb51cb3e9a1b10a2cc0c6a2d3cc92ed0c%40%3Cannounce.apache.org%3E
- https://www.exploit-db.com/exploits/42283/
- http://activemq.apache.org/security-advisories.data/CVE-2016-3088-announcement.txt
- http://rhn.redhat.com/errata/RHSA-2016-2036.html
- http://www.securitytracker.com/id/1035951
Get alerted when CVE-2016-3088 or the next vulnerability affects your stack