What’s Vulnerable › Vulnerabilities
CVE-2016-3101
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-02-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the Extra Columns plugin before 1.17 in Jenkins allows remote attackers to inject arbitrary web script or HTML by leveraging failure to filter tool tips through the configured markup formatter.
Affected products
- Jenkins project Jenkins Extra Columns Plugin: before 1.17 — fixed in 1.17
How to fix
Upgrade to a fixed version: Jenkins project Jenkins Extra Columns Plugin 1.17. Check the vendor advisory for mitigations.
References
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2016-04-11
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2016-04-11
Get alerted when CVE-2016-3101 or the next vulnerability affects your stack