What’s Vulnerable › Vulnerabilities
CVE-2016-3427: Oracle Java SE and JRockit Unspecified Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2023-05-12
- EPSS: 92.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-04-21 · updated 2026-06-17
- Weakness: CWE-284
Description
Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77; and JRockit R28.3.9 allows remote attackers to affect confidentiality, integrity, and availability via vectors related to JMX.
Affected products
- Apache Software Foundation Apache Cassandra: from 2.1.0 before 2.1.22; from 2.2.0 before 2.2.18; from 3.0.0 before 3.0.22; from 3.11.0 before 3.11.8; 4.0.0-beta1 — fixed in 2.1.22, 2.2.18, 3.0.22, 3.11.8
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10, 16.04
- Debian Linux: 8.0
- NetApp E-Series Santricity Management Plug-Ins: all versions
- NetApp E-Series Santricity Storage Manager: all versions
- NetApp E-Series Santricity Web Services: all versions
- NetApp Oncommand Balance: all versions
- NetApp OnCommand Cloud Manager: all versions
- OnCommand Insight: all versions
- NetApp Oncommand Performance Manager: all versions
- NetApp Oncommand Report: all versions
- NetApp Oncommand Shift: all versions
- NetApp OnCommand Unified Manager for 7-Mode (core package): all versions
- NetApp OnCommand Workflow Automation: all versions
- NetApp StorageGRID: through 9.0.4
- NetApp Vasa Provider For Clustered Data Ontap: from 7.2
- NetApp Virtual Storage Console: from 7.2
- openSUSE Leap: 42.1
- Opensuse: 13.1, 13.2
- Oracle Java SE: 1.6.0-update113, 1.7.0-update99, 1.8.0-update77
- Oracle Java SE: 1.6.0-update113, 1.7.0-update99, 1.8.0-update77
- Oracle JRockit: r28.3.9
- Oracle Corporation Oracle Linux: 5, 6, 7
- RedHat Enterprise Linux Desktop: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Eus: 6.7, 7.2, 7.3, 7.4, 7.5, 7.6 (+1)
- RedHat Enterprise Linux Server: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.2, 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Eus: 6.7, 7.2
- RedHat Enterprise Linux Server Tus: 7.2, 7.3, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 5.0, 6.0, 7.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Cassandra 2.1.22, 2.2.18, 3.0.22, 3.11.8. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00022.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00039.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00040.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00042.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00058.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00059.html
Get alerted when CVE-2016-3427 or the next vulnerability affects your stack