What’s Vulnerable › Vulnerabilities
CVE-2016-3654
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-04-12 · updated 2026-06-17
- Weakness: CWE-20
Description
The device management command line interface (CLI) in Palo Alto Networks PAN-OS before 5.0.18, 5.1.x before 5.1.11, 6.0.x before 6.0.13, 6.1.x before 6.1.10, and 7.0.x before 7.0.5H2 allows remote authenticated administrators to execute arbitrary OS commands via an SSH command parameter.
Affected products
- Palo Alto Networks PAN-OS: from 5.0.0 before 5.0.18; from 5.1 before 5.1.11; from 6.0.0 before 6.0.13; from 6.1.0 before 6.1.10; from 7.0.0 through 7.0.5 — fixed in 5.0.18, 5.1.11, 6.0.13, 6.1.10
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 5.0.18, 5.1.11, 6.0.13, 6.1.10. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2016-3654
- https://security.paloaltonetworks.com/CVE-2016-3654
Get alerted when CVE-2016-3654 or the next vulnerability affects your stack