What’s Vulnerable › Vulnerabilities
CVE-2016-3674
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-05-17 · updated 2026-10-08
- Weakness: CWE-200
Description
Multiple XML external entity (XXE) vulnerabilities in the (1) Dom4JDriver, (2) DomDriver, (3) JDomDriver, (4) JDom2Driver, (5) SjsxpDriver, (6) StandardStaxDriver, and (7) WstxDriver drivers in XStream before 1.4.9 allow remote attackers to read arbitrary files via a crafted XML document.
Affected products
- Debian Linux: 8.0
- Fedoraproject Fedora: 22, 23
- RedHat Jboss Middleware: 1
- x-stream xstream: before 1.4.9 — fixed in 1.4.9
How to fix
Upgrade to a fixed version: x-stream xstream 1.4.9. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/183180.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/183208.html
- http://rhn.redhat.com/errata/RHSA-2016-2822.html
- http://rhn.redhat.com/errata/RHSA-2016-2823.html
- http://www.debian.org/security/2016/dsa-3575
- http://www.openwall.com/lists/oss-security/2016/03/25/8
- http://www.openwall.com/lists/oss-security/2016/03/28/1
- http://www.securityfocus.com/bid/85381
- http://www.securitytracker.com/id/1036419
- http://x-stream.github.io/changes.html#1.4.9
- https://github.com/x-stream/xstream/issues/25
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/183180.html
Get alerted when CVE-2016-3674 or the next vulnerability affects your stack