What’s Vulnerable › Vulnerabilities
CVE-2016-3709
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-28 · updated 2026-10-14
- Weakness: CWE-79
Description
Possible cross-site scripting vulnerability in libxml after commit 960f0e2.
Affected products
- xmlsoft libxml2: from 2.9.2 before 2.9.11 — fixed in 2.9.11
How to fix
Upgrade to a fixed version: xmlsoft libxml2 2.9.11. Check the vendor advisory for mitigations.
References
- https://mail.gnome.org/archives/xml/2018-January/msg00010.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00021.html
- https://mail.gnome.org/archives/xml/2018-January/msg00010.html
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
Get alerted when CVE-2016-3709 or the next vulnerability affects your stack