What’s Vulnerable › Vulnerabilities
CVE-2016-3715: ImageMagick Arbitrary File Deletion Vulnerability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 75.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-05-05 · updated 2026-06-17
- Weakness: CWE-552
Description
The EPHEMERAL coder in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allows remote attackers to delete arbitrary files via a crafted image.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10, 16.04
- ImageMagick: before 6.9.3-10; 7.0.0-0, 7.0.1-0 — fixed in 6.9.3-10
- openSUSE Leap: 42.1
- Opensuse: 13.2
- Oracle Corporation Oracle Linux: 6, 7
- Oracle Corporation Solaris Operating System: 10, 11.3
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Eus: 6.7, 7.2, 7.3, 7.4, 7.5, 7.6 (+1)
- RedHat Enterprise Linux For Ibm Z Systems: 6.0_s390x, 7.0_s390x
- RedHat Enterprise Linux For Ibm Z Systems Eus: 6.7_s390x, 7.2_s390x, 7.3_s390x, 7.4_s390x, 7.5_s390x, 7.6_s390x (+1)
- RedHat Enterprise Linux For Power Big Endian: 6.0_ppc64, 7.0_ppc64
- RedHat Enterprise Linux For Power Big Endian Eus: 6.7_ppc64, 7.2_ppc64, 7.3_ppc64, 7.4_ppc64, 7.5_ppc64, 7.6_ppc64 (+1)
- RedHat Enterprise Linux For Power Little Endian: 7.0_ppc64le
- RedHat Enterprise Linux For Power Little Endian Eus: 7.2_ppc64le, 7.3_ppc64le, 7.4_ppc64le, 7.5_ppc64le, 7.6_ppc64le, 7.7_ppc64le
- RedHat Enterprise Linux Hpc Node: 6.0, 7.0
- RedHat Enterprise Linux Hpc Node Eus: 7.2
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.2, 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server From Rhui: 6.0, 7.0
- RedHat Enterprise Linux Server Supplementary Eus: 6.7z
- RedHat Enterprise Linux Server Tus: 7.2, 7.3, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- SUSE Linux Enterprise Debuginfo: 11-sp2, 11-sp3, 11-sp4
- SUSE Linux Enterprise Server 15 SP1: 12, 12-sp1
- SUSE Linux Enterprise Server: 11-sp2, 11-sp3, 11-sp4, 12, 12-sp1
- SUSE Linux Enterprise Software Development Kit: 11-sp4, 12, 12-sp1
- SUSE Linux Enterprise Workstation Extension: 12, 12-sp1
- SUSE Manager: 2.1
- SUSE Manager Proxy: 2.1
- SUSE Openstack Cloud: 5
How to fix
Upgrade to a fixed version: ImageMagick 6.9.3-10. Check the vendor advisory for mitigations.
References
- http://git.imagemagick.org/repos/ImageMagick/blob/a01518e08c840577cabd7d3ff291a9ba735f7276/ChangeLog
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00024.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00025.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00028.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00032.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00051.html
- http://rhn.redhat.com/errata/RHSA-2016-0726.html
- http://www.debian.org/security/2016/dsa-3580
- http://www.debian.org/security/2016/dsa-3746
- http://www.openwall.com/lists/oss-security/2016/05/03/18
- http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html
- http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html
Get alerted when CVE-2016-3715 or the next vulnerability affects your stack