What’s Vulnerable › Vulnerabilities

CVE-2016-3841

Description

The IPv6 stack in the Linux kernel before 4.3.3 mishandles options data, which allows local users to gain privileges or cause a denial of service (use-after-free and system crash) via a crafted sendmsg system call.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.12.52, 3.16.35, 3.18.25, 3.2.75. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-3841 or the next vulnerability affects your stack