What’s Vulnerable › Vulnerabilities
CVE-2016-3955
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 25.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-07-03 · updated 2026-06-17
- Weakness: CWE-119
Description
The usbip_recv_xbuff function in drivers/usb/usbip/usbip_common.c in the Linux kernel before 4.5.3 allows remote attackers to cause a denial of service (out-of-bounds write) or possibly have unspecified other impact via a crafted length value in a USB/IP packet.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10
- Debian Linux: 8.0
- Linux kernel: before 3.2.80; from 3.3 before 3.10.102; from 3.11 before 3.12.59; from 3.13 before 3.14.68; from 3.17 before 3.18.37; from 3.19 before 4.1.28 — fixed in 3.10.102, 3.12.59, 3.14.68, 3.18.37, 3.2.80, 4.1.28
How to fix
Upgrade to a fixed version: Linux kernel 3.10.102, 3.12.59, 3.14.68, 3.18.37. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=b348d7dddb6c4fbfc810b7a0626e8ec9e29f7cbb
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00044.html
- http://www.debian.org/security/2016/dsa-3607
- http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.5.3
- http://www.openwall.com/lists/oss-security/2016/04/19/1
- http://www.securityfocus.com/bid/86534
- http://www.ubuntu.com/usn/USN-2989-1
- http://www.ubuntu.com/usn/USN-2996-1
- http://www.ubuntu.com/usn/USN-2997-1
- http://www.ubuntu.com/usn/USN-2998-1
- http://www.ubuntu.com/usn/USN-3000-1
- http://www.ubuntu.com/usn/USN-3001-1
Get alerted when CVE-2016-3955 or the next vulnerability affects your stack