What’s Vulnerable › Vulnerabilities
CVE-2016-4029
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-08-07 · updated 2026-06-17
- Weakness: CWE-918
Description
WordPress before 4.5 does not consider octal and hexadecimal IP address formats when determining an intranet address, which allows remote attackers to bypass an intended SSRF protection mechanism via a crafted address.
Affected products
- Debian Linux: 8.0
- WordPress: before 4.5 — fixed in 4.5
How to fix
Upgrade to a fixed version: WordPress 4.5. Check the vendor advisory for mitigations.
References
- http://codex.wordpress.org/Version_4.5
- http://www.debian.org/security/2016/dsa-3681
- http://www.securitytracker.com/id/1036594
- https://core.trac.wordpress.org/query?status=closed&milestone=4.5
- https://wpvulndb.com/vulnerabilities/8473
- http://codex.wordpress.org/Version_4.5
- http://www.debian.org/security/2016/dsa-3681
- http://www.securitytracker.com/id/1036594
- https://core.trac.wordpress.org/query?status=closed&milestone=4.5
- https://wpvulndb.com/vulnerabilities/8473
Get alerted when CVE-2016-4029 or the next vulnerability affects your stack