What’s Vulnerable › Vulnerabilities
CVE-2016-4429
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-06-10 · updated 2026-06-17
- Weakness: CWE-787
Description
Stack-based buffer overflow in the clntudp_call function in sunrpc/clnt_udp.c in the GNU C Library (aka glibc or libc6) allows remote servers to cause a denial of service (crash) or possibly unspecified other impact via a flood of crafted ICMP and UDP packets.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04
- GNU C Library (glibc): before 2.24 — fixed in 2.24
- openSUSE Leap: 42.1
- Opensuse: 13.2
How to fix
Upgrade to a fixed version: GNU C Library (glibc) 2.24. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2016-06/msg00030.html
- http://lists.opensuse.org/opensuse-updates/2016-07/msg00039.html
- http://www-01.ibm.com/support/docview.wss?uid=swg21995039
- http://www.securityfocus.com/bid/102073
- https://lists.debian.org/debian-lts-announce/2020/06/msg00027.html
- https://source.android.com/security/bulletin/2017-12-01
- https://sourceware.org/bugzilla/show_bug.cgi?id=20112
- https://sourceware.org/git/gitweb.cgi?p=glibc.git%3Bh=bc779a1a5b3035133024b21e2f339fe4219fb11c
- https://usn.ubuntu.com/3759-1/
- https://usn.ubuntu.com/3759-2/
- https://www.oracle.com//security-alerts/cpujul2021.html
- http://lists.opensuse.org/opensuse-updates/2016-06/msg00030.html
Get alerted when CVE-2016-4429 or the next vulnerability affects your stack