What’s Vulnerable › Vulnerabilities
CVE-2016-4432
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-06-01 · updated 2026-06-17
- Weakness: CWE-287
Description
The AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication and consequently perform actions via vectors related to connection state logging.
Affected products
- Apache Software Foundation Apache Qpid Broker-J: before 6.0.3 — fixed in 6.0.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Qpid Broker-J 6.0.3. Check the vendor advisory for mitigations.
References
- http://mail-archives.apache.org/mod_mbox/qpid-users/201605.mbox/%3CCAFEMS4tXDKYxKVMmU0zTb_7uzduoUS4_RePnUwz1tj%2BGQLNw5Q%40mail.gmail.com%3E
- http://packetstormsecurity.com/files/137216/Apache-Qpid-Java-Broker-6.0.2-Authentication-Bypass.html
- http://www.securityfocus.com/archive/1/538508/100/0/threaded
- http://www.securitytracker.com/id/1035983
- https://issues.apache.org/jira/browse/QPID-7257
- https://svn.apache.org/viewvc?view=revision&revision=1743161
- https://svn.apache.org/viewvc?view=revision&revision=1743393
- http://mail-archives.apache.org/mod_mbox/qpid-users/201605.mbox/%3CCAFEMS4tXDKYxKVMmU0zTb_7uzduoUS4_RePnUwz1tj%2BGQLNw5Q%40mail.gmail.com%3E
- http://packetstormsecurity.com/files/137216/Apache-Qpid-Java-Broker-6.0.2-Authentication-Bypass.html
- http://www.securityfocus.com/archive/1/538508/100/0/threaded
- http://www.securitytracker.com/id/1035983
- https://issues.apache.org/jira/browse/QPID-7257
Get alerted when CVE-2016-4432 or the next vulnerability affects your stack