What’s Vulnerable › Vulnerabilities
CVE-2016-4450
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-06-07 · updated 2026-06-17
- Weakness: CWE-476
Description
os/unix/ngx_files.c in nginx before 1.10.1 and 1.11.x before 1.11.1 allows remote attackers to cause a denial of service (NULL pointer dereference and worker process crash) via a crafted request, involving writing a client request body to a temporary file.
Affected products
- Canonical Ubuntu Linux: 14.04, 15.10, 16.04
- Debian Linux: 8.0
- nginx: from 1.3.9 before 1.10.1; 1.11.0 — fixed in 1.10.1
How to fix
Upgrade to a fixed version: nginx 1.10.1. Check the vendor advisory for mitigations.
References
- http://mailman.nginx.org/pipermail/nginx-announce/2016/000179.html
- http://www.debian.org/security/2016/dsa-3592
- http://www.securityfocus.com/bid/90967
- http://www.securitytracker.com/id/1036019
- http://www.ubuntu.com/usn/USN-2991-1
- https://access.redhat.com/errata/RHSA-2016:1425
- https://security.gentoo.org/glsa/201606-06
- http://mailman.nginx.org/pipermail/nginx-announce/2016/000179.html
- http://www.debian.org/security/2016/dsa-3592
- http://www.securityfocus.com/bid/90967
- http://www.securitytracker.com/id/1036019
- http://www.ubuntu.com/usn/USN-2991-1
Get alerted when CVE-2016-4450 or the next vulnerability affects your stack