What’s Vulnerable › Vulnerabilities
CVE-2016-4461
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-10-16 · updated 2026-06-17
- Weakness: CWE-20
Description
Apache Struts 2.x before 2.3.29 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation. NOTE: this vulnerability exists because of an incomplete fix for CVE-2016-0785.
Affected products
- Apache Struts: from 2.0.0 before 2.3.29 — fixed in 2.3.29
- NetApp Oncommand Balance: all versions
How to fix
Upgrade to a fixed version: Apache Struts 2.3.29. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/91277
- https://security.netapp.com/advisory/ntap-20180629-0004/
- https://struts.apache.org/docs/s2-036.html
- http://www.securityfocus.com/bid/91277
- https://security.netapp.com/advisory/ntap-20180629-0004/
- https://struts.apache.org/docs/s2-036.html
Get alerted when CVE-2016-4461 or the next vulnerability affects your stack