What’s Vulnerable › Vulnerabilities
CVE-2016-4472
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-06-30 · updated 2026-10-08
- Weakness: CWE-119
Description
The overflow protection in Expat is removed by compilers with certain optimization settings, which allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via crafted XML data. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-1283 and CVE-2015-2716.
Affected products
- Canonical Ubuntu Linux: 12.04
- libexpat project libexpat: through 2.1.1
- McAfee,LLC McAfee Policy Auditor: before 6.5.1 — fixed in 6.5.1
- Python: from 2.7.0 before 2.7.15; from 3.3.0 before 3.3.7; from 3.4.0 before 3.4.7; from 3.5.0 before 3.5.4; from 3.6.0 before 3.6.2 — fixed in 2.7.15, 3.3.7, 3.4.7, 3.5.4, 3.6.2
How to fix
Upgrade to a fixed version: McAfee,LLC McAfee Policy Auditor 6.5.1; Python 2.7.15, 3.3.7, 3.4.7, 3.5.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/91528
- http://www.ubuntu.com/usn/USN-3013-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1344251
- https://kc.mcafee.com/corporate/index?page=content&id=SB10365
- https://security.gentoo.org/glsa/201701-21
- https://sourceforge.net/p/expat/code_git/ci/f0bec73b018caa07d3e75ec8dd967f3785d71bde
- https://www.tenable.com/security/tns-2016-20
- http://www.securityfocus.com/bid/91528
- http://www.ubuntu.com/usn/USN-3013-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1344251
- https://kc.mcafee.com/corporate/index?page=content&id=SB10365
- https://security.gentoo.org/glsa/201701-21
Get alerted when CVE-2016-4472 or the next vulnerability affects your stack