What’s Vulnerable › Vulnerabilities

CVE-2016-4658

Description

xpointer.c in libxml2 before 2.9.5 (as used in Apple iOS before 10, OS X before 10.12, tvOS before 10, and watchOS before 3, and other products) does not forbid namespace nodes in XPointer ranges, which allows remote attackers to execute arbitrary code or cause a denial of service (use-after-free and memory corruption) via a crafted XML document.

Affected products

How to fix

Upgrade to a fixed version: Apple Iphone Os 10.0; macOS 10.12; Apple tvOS 10.0; Apple watchOS 3.0; xmlsoft libxml2 2.9.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-4658 or the next vulnerability affects your stack