What’s Vulnerable › Vulnerabilities
CVE-2016-4688
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-02-20 · updated 2026-06-17
- Weakness: CWE-119
Description
An issue was discovered in certain Apple products. iOS before 10.1 is affected. macOS before 10.12.1 is affected. tvOS before 10.0.1 is affected. watchOS before 3.1 is affected. watchOS before 3.1.3 is affected. The issue involves the "FontParser" component. It allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow and application crash) via a crafted font.
Affected products
- macOS: before 10.12.1 — fixed in 10.12.1
- Apple tvOS: before 10.0.1 — fixed in 10.0.1
- Apple watchOS: before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: macOS 10.12.1; Apple tvOS 10.0.1; Apple watchOS 3.1.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/94572
- http://www.securitytracker.com/id/1037469
- https://support.apple.com/HT207269
- https://support.apple.com/HT207270
- https://support.apple.com/HT207271
- https://support.apple.com/HT207275
- https://support.apple.com/HT207487
- http://www.securityfocus.com/bid/94572
- http://www.securitytracker.com/id/1037469
- https://support.apple.com/HT207269
- https://support.apple.com/HT207270
- https://support.apple.com/HT207271
Get alerted when CVE-2016-4688 or the next vulnerability affects your stack