What’s Vulnerable › Vulnerabilities
CVE-2016-4794
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-05-23 · updated 2026-06-17
Description
Use-after-free vulnerability in mm/percpu.c in the Linux kernel through 4.6 allows local users to cause a denial of service (BUG) or possibly have unspecified other impact via crafted use of the mmap and bpf system calls.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04
- Linux kernel: from 3.18 before 3.18.37; from 3.19 before 4.1.28; from 4.2 before 4.4.16; from 4.5 before 4.6.5 — fixed in 3.18.37, 4.1.28, 4.4.16, 4.6.5
How to fix
Upgrade to a fixed version: Linux kernel 3.18.37, 4.1.28, 4.4.16, 4.6.5. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2016-2574.html
- http://rhn.redhat.com/errata/RHSA-2016-2584.html
- http://www.openwall.com/lists/oss-security/2016/05/12/6
- http://www.securityfocus.com/bid/90625
- http://www.ubuntu.com/usn/USN-3053-1
- http://www.ubuntu.com/usn/USN-3054-1
- http://www.ubuntu.com/usn/USN-3055-1
- http://www.ubuntu.com/usn/USN-3056-1
- http://www.ubuntu.com/usn/USN-3057-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1335889
- https://lkml.org/lkml/2016/4/17/125
- https://source.android.com/security/bulletin/2016-12-01.html
Get alerted when CVE-2016-4794 or the next vulnerability affects your stack