What’s Vulnerable › Vulnerabilities

CVE-2016-4805

Description

Use-after-free vulnerability in drivers/net/ppp/ppp_generic.c in the Linux kernel before 4.5.2 allows local users to cause a denial of service (memory corruption and system crash, or spinlock) or possibly have unspecified other impact by removing a network namespace, related to the ppp_register_net_channel and ppp_unregister_channel functions.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.10.102, 3.12.59, 3.14.67, 3.16.35. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-4805 or the next vulnerability affects your stack