What’s Vulnerable › Vulnerabilities
CVE-2016-4971
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 46.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-06-30 · updated 2026-06-17
Description
GNU wget before 1.18 allows remote servers to write to arbitrary files by redirecting a request from HTTP to a crafted FTP resource.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10, 16.04
- gnuwget wget: before 1.18 — fixed in 1.18
- Oracle Corporation Solaris Operating System: 10, 11.3
- Palo Alto Networks PAN-OS: from 6.1.0 through 6.1.16; from 7.0.0 through 7.0.14; from 7.1.0 through 7.1.9
How to fix
Upgrade to a fixed version: gnuwget wget 1.18. Check the vendor advisory for mitigations.
References
- http://git.savannah.gnu.org/cgit/wget.git/commit/?id=e996e322ffd42aaa051602da182d03178d0f13e1
- http://lists.gnu.org/archive/html/info-gnu/2016-06/msg00004.html
- http://lists.opensuse.org/opensuse-updates/2016-08/msg00043.html
- http://packetstormsecurity.com/files/162395/GNU-wget-Arbitrary-File-Upload-Code-Execution.html
- http://rhn.redhat.com/errata/RHSA-2016-2587.html
- http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html
- http://www.securityfocus.com/bid/91530
- http://www.securitytracker.com/id/1036133
- http://www.ubuntu.com/usn/USN-3012-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1343666
- https://security.gentoo.org/glsa/201610-11
- https://security.paloaltonetworks.com/CVE-2016-4971
Get alerted when CVE-2016-4971 or the next vulnerability affects your stack