What’s Vulnerable › Vulnerabilities
CVE-2016-4988
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-02-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the Build Failure Analyzer plugin before 1.16.0 in Jenkins allows remote attackers to inject arbitrary web script or HTML via an unspecified parameter.
Affected products
- Jenkins project Jenkins Build Failure Analyzer Plugin: before 1.16.0 — fixed in 1.16.0
How to fix
Upgrade to a fixed version: Jenkins project Jenkins Build Failure Analyzer Plugin 1.16.0. Check the vendor advisory for mitigations.
References
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2016-06-20
- https://jenkins.io/security/advisory/2016-06-20/
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2016-06-20
Get alerted when CVE-2016-4988 or the next vulnerability affects your stack