What’s Vulnerable › Vulnerabilities
CVE-2016-4994
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-07-12 · updated 2026-06-17
- Weakness: CWE-416
Description
Use-after-free vulnerability in the xcf_load_image function in app/xcf/xcf-load.c in GIMP allows remote attackers to cause a denial of service (program crash) or possibly execute arbitrary code via a crafted XCF file.
Affected products
- GIMP: before 2.8.18 — fixed in 2.8.18
How to fix
Upgrade to a fixed version: GIMP 2.8.18. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2016-07/msg00005.html
- http://rhn.redhat.com/errata/RHSA-2016-2589.html
- http://www.debian.org/security/2016/dsa-3612
- http://www.securityfocus.com/bid/91425
- http://www.securitytracker.com/id/1036226
- http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.431987
- http://www.ubuntu.com/usn/USN-3025-1
- https://bugzilla.gnome.org/show_bug.cgi?id=767873
- https://git.gnome.org/browse/gimp/commit/?id=e82aaa4b4ee0703c879e35ea9321fff6be3e9b6f
- http://lists.opensuse.org/opensuse-updates/2016-07/msg00005.html
- http://rhn.redhat.com/errata/RHSA-2016-2589.html
- http://www.debian.org/security/2016/dsa-3612
Get alerted when CVE-2016-4994 or the next vulnerability affects your stack