What’s Vulnerable › Vulnerabilities
CVE-2016-4997
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-07-03 · updated 2026-06-17
- Weakness: CWE-264
Description
The compat IPT_SO_SET_REPLACE and IP6T_SO_SET_REPLACE setsockopt implementations in the netfilter subsystem in the Linux kernel before 4.6.3 allow local users to gain privileges or cause a denial of service (memory corruption) by leveraging in-container root access to provide a crafted offset value that triggers an unintended decrement.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10, 16.04
- Debian Linux: 8.0
- Linux kernel: from 2.6.17 before 3.2.80; from 3.3 before 3.10.103; from 3.11 before 3.12.62; from 3.13 before 3.14.73; from 3.15 before 3.16.37; from 3.17 before 3.18.37 — fixed in 3.10.103, 3.12.62, 3.14.73, 3.16.37, 3.18.37, 3.2.80
- Novell Suse Linux Enterprise Desktop: 12.0, 12.0-sp1
- Novell Suse Linux Enterprise Live Patching: 12.0
- Novell Suse Linux Enterprise Module For Public Cloud: 12.0
- Novell Suse Linux Enterprise Real Time Extension: 12.0-sp1
- Novell Suse Linux Enterprise Server: 12.0, 12.0-sp1
- Novell Suse Linux Enterprise Software Development Kit: 12.0, 12.0-sp1
- Novell Suse Linux Enterprise Workstation Extension: 12.0, 12.0-sp1
- Oracle Corporation Oracle Linux: 7
How to fix
Upgrade to a fixed version: Linux kernel 3.10.103, 3.12.62, 3.14.73, 3.16.37. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=ce683e5f9d045e5d67d1312a42b359cb2ab2a13c
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00060.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00061.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00044.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00048.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00050.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00051.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00052.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00053.html
Get alerted when CVE-2016-4997 or the next vulnerability affects your stack