What’s Vulnerable › Vulnerabilities
CVE-2016-5118
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 50.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-06-10 · updated 2026-06-17
Description
The OpenBlob function in blob.c in GraphicsMagick before 1.3.24 and ImageMagick allows remote attackers to execute arbitrary code via a | (pipe) character at the start of a filename.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10, 16.04
- Debian Linux: 8.0
- GraphicsMagick: through 1.3.23
- ImageMagick: before 7.0.1-7 — fixed in 7.0.1-7
- openSUSE Leap: 42.1
- Opensuse: 13.2
- Oracle Corporation Oracle Linux: 6, 7
- Oracle Corporation Solaris Operating System: 10, 11.3
- SUSE Linux Enterprise Debuginfo: 11-sp4
- SUSE Linux Enterprise Server 15 SP1: 12, 12.0-sp1
- SUSE Linux Enterprise Server: 12, 12.0-sp1
- SUSE Linux Enterprise Software Development Kit: 11-sp4, 12, 12.0-sp1
- SUSE Linux Enterprise Workstation Extension: 12, 12-sp1
- SUSE Studio onsite: 1.3
How to fix
Upgrade to a fixed version: ImageMagick 7.0.1-7. Check the vendor advisory for mitigations.
References
- http://git.imagemagick.org/repos/ImageMagick/commit/40639d173aa8c76b850d625c630b711fee4dcfb8
- http://hg.code.sf.net/p/graphicsmagick/code/file/41876934e762/ChangeLog
- http://hg.code.sf.net/p/graphicsmagick/code/rev/ae3928faa858
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00009.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00030.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00032.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00047.html
- http://www.debian.org/security/2016/dsa-3591
- http://www.debian.org/security/2016/dsa-3746
Get alerted when CVE-2016-5118 or the next vulnerability affects your stack