What’s Vulnerable › Vulnerabilities

CVE-2016-5180

Description

Heap-based buffer overflow in the ares_create_query function in c-ares 1.x before 1.12.0 allows remote attackers to cause a denial of service (out-of-bounds write) or possibly execute arbitrary code via a hostname with an escaped trailing dot.

Affected products

How to fix

Upgrade to a fixed version: Node.js 0.10.48, 0.12.17, 4.6.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-5180 or the next vulnerability affects your stack