What’s Vulnerable › Vulnerabilities
CVE-2016-5287
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-416
Description
A potentially exploitable use-after-free crash during actor destruction with service workers. This issue does not affect releases earlier than Firefox 49. This vulnerability affects Firefox < 49.0.2.
Affected products
- Mozilla Firefox: before 49.0.2 — fixed in 49.0.2
How to fix
Upgrade to a fixed version: Mozilla Firefox 49.0.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/93811
- http://www.securitytracker.com/id/1037077
- https://bugzilla.mozilla.org/show_bug.cgi?id=1309823
- https://www.mozilla.org/security/advisories/mfsa2016-87/
- http://www.securityfocus.com/bid/93811
- http://www.securitytracker.com/id/1037077
- https://bugzilla.mozilla.org/show_bug.cgi?id=1309823
- https://www.mozilla.org/security/advisories/mfsa2016-87/
Get alerted when CVE-2016-5287 or the next vulnerability affects your stack