What’s Vulnerable › Vulnerabilities
CVE-2016-5300
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-06-16 · updated 2026-06-17
- Weakness: CWE-399
Description
The XML parser in Expat does not use sufficient entropy for hash initialization, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted identifiers in an XML document. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-0876.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10, 16.04
- Debian Linux: 8.0
- Android: 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1
- libexpat project libexpat: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: libexpat project libexpat 2.2.0. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2016/dsa-3597
- http://www.openwall.com/lists/oss-security/2016/06/04/4
- http://www.openwall.com/lists/oss-security/2016/06/04/5
- http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html
- http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html
- http://www.securityfocus.com/bid/91159
- http://www.ubuntu.com/usn/USN-3010-1
- https://kc.mcafee.com/corporate/index?page=content&id=SB10365
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://security.gentoo.org/glsa/201701-21
- https://source.android.com/security/bulletin/2016-11-01.html
Get alerted when CVE-2016-5300 or the next vulnerability affects your stack