What’s Vulnerable › Vulnerabilities
CVE-2016-5384
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-08-13 · updated 2026-06-17
- Weakness: CWE-415
Description
fontconfig before 2.12.1 does not validate offsets, which allows local users to trigger arbitrary free calls and consequently conduct double free attacks and execute arbitrary code via a crafted cache file.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04
- Debian Linux: 8.0
- Fedoraproject Fedora: 23, 24
- fontconfig project fontconfig: before 2.12.1 — fixed in 2.12.1
How to fix
Upgrade to a fixed version: fontconfig project fontconfig 2.12.1. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2016-2601.html
- http://www.debian.org/security/2016/dsa-3644
- http://www.securityfocus.com/bid/92339
- http://www.ubuntu.com/usn/USN-3063-1
- https://cgit.freedesktop.org/fontconfig/commit/?id=7a4a5bd7897d216f0794ca9dbce0a4a5c9d14940
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6CJ45VRAMCIISHOVKFVOQYQUSTUJP7FC/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GGOS4YYB7UYAWX5AEXJZHDIX4ZMSXSW5/
- https://lists.freedesktop.org/archives/fontconfig/2016-August/005792.html
- http://rhn.redhat.com/errata/RHSA-2016-2601.html
- http://www.debian.org/security/2016/dsa-3644
- http://www.securityfocus.com/bid/92339
- http://www.ubuntu.com/usn/USN-3063-1
Get alerted when CVE-2016-5384 or the next vulnerability affects your stack