What’s Vulnerable › Vulnerabilities

CVE-2016-5385

Description

PHP through 7.0.8 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect an application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, as demonstrated by (1) an application that makes a getenv('HTTP_PROXY') call or (2) a CGI configuration of PHP, aka an "httpoxy" issue.

Affected products

How to fix

Upgrade to a fixed version: Drupal 8.1.7; PHP 5.5.38, 5.6.24. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-5385 or the next vulnerability affects your stack