What’s Vulnerable › Vulnerabilities
CVE-2016-5394
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-07-19 · updated 2026-06-17
- Weakness: CWE-79
Description
In the XSS Protection API module before 1.0.12 in Apache Sling, the encoding done by the XSSAPI.encodeForJSString() method is not restrictive enough and for some input patterns allows script tags to pass through unencoded, leading to potential XSS vulnerabilities.
Affected products
- Apache Software Foundation Apache Sling: before 1.0.12 — fixed in 1.0.12
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Sling 1.0.12. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/99870
- https://lists.apache.org/thread.html/332166037a54b97cf41e2b616aaed38439de94b19b204841478e4525%40%3Cdev.sling.apache.org%3E
- http://www.securityfocus.com/bid/99870
- https://lists.apache.org/thread.html/332166037a54b97cf41e2b616aaed38439de94b19b204841478e4525%40%3Cdev.sling.apache.org%3E
Get alerted when CVE-2016-5394 or the next vulnerability affects your stack