What’s Vulnerable › Vulnerabilities
CVE-2016-5431
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-07 · updated 2026-06-17
- Weakness: CWE-327
Description
The PHP JOSE Library by Gree Inc. before version 2.2.1 is vulnerable to key confusion/algorithm substitution in the JWS component resulting in bypassing the signature verification via crafted tokens.
Affected products
- jose-php: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: jose-php 2.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/nov/jose-php/commit/1cce55e27adf0274193eb1cd74b927a398a3df4b
- https://github.com/nov/jose-php/commit/1cce55e27adf0274193eb1cd74b927a398a3df4b
Get alerted when CVE-2016-5431 or the next vulnerability affects your stack