What’s Vulnerable › Vulnerabilities
CVE-2016-5584
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-10-25 · updated 2026-06-17
Description
Unspecified vulnerability in Oracle MySQL 5.5.52 and earlier, 5.6.33 and earlier, and 5.7.15 and earlier allows remote administrators to affect confidentiality via vectors related to Server: Security: Encryption.
Affected products
- Debian Linux: 8.0
- MariaDB: from 5.5.0 before 5.5.53; from 10.0.0 before 10.0.28; from 10.1.0 before 10.1.19 — fixed in 10.0.28, 10.1.19, 5.5.53
- MySQL Server: from 5.5.0 through 5.5.52; from 5.6.0 through 5.6.33; from 5.7.0 through 5.7.15
How to fix
Upgrade to a fixed version: MariaDB 10.0.28, 10.1.19, 5.5.53. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2016/dsa-3706
- http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.html
- http://www.securityfocus.com/bid/93735
- http://www.securitytracker.com/id/1037050
- https://mariadb.com/kb/en/mariadb/mariadb-10028-release-notes/
- https://security.gentoo.org/glsa/201701-01
- http://www.debian.org/security/2016/dsa-3706
- http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.html
- http://www.securityfocus.com/bid/93735
- http://www.securitytracker.com/id/1037050
- https://mariadb.com/kb/en/mariadb/mariadb-10028-release-notes/
- https://security.gentoo.org/glsa/201701-01
Get alerted when CVE-2016-5584 or the next vulnerability affects your stack