What’s Vulnerable › Vulnerabilities
CVE-2016-5682
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-04-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Swagger-UI before 2.2.1 has XSS via the Default field in the Definitions section.
Affected products
- Swagger-UI before 2.2.1: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: Swagger-UI before 2.2.1 2.2.1. Check the vendor advisory for mitigations.
References
- https://community.rapid7.com/community/infosec/blog/2016/09/02/r7-2016-19-persistent-xss-via-unescaped-parameters-in-swagger-ui
- https://community.rapid7.com/community/infosec/blog/2016/09/02/r7-2016-19-persistent-xss-via-unescaped-parameters-in-swagger-ui
Get alerted when CVE-2016-5682 or the next vulnerability affects your stack