What’s Vulnerable › Vulnerabilities
CVE-2016-5713
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-06 · updated 2026-06-17
- Weakness: CWE-94
Description
Versions of Puppet Agent prior to 1.6.0 included a version of the Puppet Execution Protocol (PXP) agent that passed environment variables through to Puppet runs. This could allow unauthorized code to be loaded. This bug was first introduced in Puppet Agent 1.3.0.
Affected products
- Puppet Agent: from 1.3.0 before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Puppet Agent 1.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-5713 or the next vulnerability affects your stack