What’s Vulnerable › Vulnerabilities

CVE-2016-5770

Description

Integer overflow in the SplFileObject::fread function in spl_directory.c in the SPL extension in PHP before 5.5.37 and 5.6.x before 5.6.23 allows remote attackers to cause a denial of service or possibly have unspecified other impact via a large integer argument, a related issue to CVE-2016-5096.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.5.37, 5.6.23, 7.0.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-5770 or the next vulnerability affects your stack