What’s Vulnerable › Vulnerabilities

CVE-2016-5771

Description

spl_array.c in the SPL extension in PHP before 5.5.37 and 5.6.x before 5.6.23 improperly interacts with the unserialize implementation and garbage collection, which allows remote attackers to execute arbitrary code or cause a denial of service (use-after-free and application crash) via crafted serialized data.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.5.37, 5.6.23, 7.0.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-5771 or the next vulnerability affects your stack