What’s Vulnerable › Vulnerabilities
CVE-2016-5772
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-08-07 · updated 2026-06-17
- Weakness: CWE-415
Description
Double free vulnerability in the php_wddx_process_data function in wddx.c in the WDDX extension in PHP before 5.5.37, 5.6.x before 5.6.23, and 7.x before 7.0.8 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via crafted XML data that is mishandled in a wddx_deserialize call.
Affected products
- Debian Linux: 8.0
- openSUSE Leap: 42.1
- Opensuse: 13.2
- PHP: before 5.5.37; from 5.6.0 before 5.6.23; from 7.0.0 before 7.0.8 — fixed in 5.5.37, 5.6.23, 7.0.8
- SUSE Linux Enterprise Debuginfo: 11-sp4
- SUSE Linux Enterprise Server: 11-sp4
- SUSE Linux Enterprise Software Development Kit: 11-sp4
How to fix
Upgrade to a fixed version: PHP 5.5.37, 5.6.23, 7.0.8. Check the vendor advisory for mitigations.
References
- http://github.com/php/php-src/commit/a44c89e8af7c2410f4bfc5e097be2a5d0639a60c?w=1
- http://lists.apple.com/archives/security-announce/2016/Sep/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00025.html
- http://lists.opensuse.org/opensuse-updates/2016-08/msg00003.html
- http://php.net/ChangeLog-5.php
- http://php.net/ChangeLog-7.php
- http://rhn.redhat.com/errata/RHSA-2016-2750.html
- http://www.debian.org/security/2016/dsa-3618
- http://www.openwall.com/lists/oss-security/2016/06/23/4
- http://www.securityfocus.com/bid/91398
- https://bugs.php.net/bug.php?id=72340
Get alerted when CVE-2016-5772 or the next vulnerability affects your stack