What’s Vulnerable › Vulnerabilities

CVE-2016-5804

Description

Moxa MGate MB3180 before 1.8, MGate MB3280 before 2.7, MGate MB3480 before 2.6, MGate MB3170 before 2.5, and MGate MB3270 before 2.7 use weak encryption, which allows remote attackers to bypass authentication via a brute-force series of guesses for a parameter value.

Affected products

How to fix

Upgrade to a fixed version: Moxa Mgate Mb3170 Firmware 2.5; Moxa Mgate Mb3180 Firmware 1.8; Moxa Mgate Mb3270 Firmware 2.7; Moxa Mgate Mb3280 Firmware 2.7; Moxa Mgate Mb3480 Firmware 2.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-5804 or the next vulnerability affects your stack