What’s Vulnerable › Vulnerabilities
CVE-2016-5828
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-06-27 · updated 2026-06-17
- Weakness: CWE-20
Description
The start_thread function in arch/powerpc/kernel/process.c in the Linux kernel through 4.6.3 on powerpc platforms mishandles transactional state, which allows local users to cause a denial of service (invalid process state or TM Bad Thing exception, and system crash) or possibly have unspecified other impact by starting and suspending a transaction before an exec system call.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04
- Debian Linux: 8.0
- Linux kernel: from 3.9 before 3.10.103; from 3.11 before 3.14.74; from 3.15 before 3.16.37; from 3.17 before 3.18.37; from 3.19 before 4.1.28; from 4.2 before 4.4.16 — fixed in 3.10.103, 3.14.74, 3.16.37, 3.18.37, 4.1.28, 4.4.16
- Novell Suse Linux Enterprise Real Time Extension: 12-sp1
How to fix
Upgrade to a fixed version: Linux kernel 3.10.103, 3.14.74, 3.16.37, 3.18.37. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00044.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00055.html
- http://rhn.redhat.com/errata/RHSA-2016-2574.html
- http://www.debian.org/security/2016/dsa-3616
- http://www.openwall.com/lists/oss-security/2016/06/25/7
- http://www.securityfocus.com/bid/91415
- http://www.ubuntu.com/usn/USN-3070-1
- http://www.ubuntu.com/usn/USN-3070-2
- http://www.ubuntu.com/usn/USN-3070-3
- http://www.ubuntu.com/usn/USN-3070-4
- http://www.ubuntu.com/usn/USN-3071-1
Get alerted when CVE-2016-5828 or the next vulnerability affects your stack