What’s Vulnerable › Vulnerabilities
CVE-2016-5829
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-06-27 · updated 2026-06-17
- Weakness: CWE-119
Description
Multiple heap-based buffer overflows in the hiddev_ioctl_usage function in drivers/hid/usbhid/hiddev.c in the Linux kernel through 4.6.3 allow local users to cause a denial of service or possibly have unspecified other impact via a crafted (1) HIDIOCGUSAGES or (2) HIDIOCSUSAGES ioctl call.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04
- Debian Linux: 8.0
- Linux kernel: before 3.2.82; from 3.3 before 3.10.103; from 3.11 before 3.12.62; from 3.13 before 3.14.74; from 3.15 before 3.16.37; from 3.17 before 3.18.37 — fixed in 3.10.103, 3.12.62, 3.14.74, 3.16.37, 3.18.37, 3.2.82
- Novell Suse Linux Enterprise Real Time Extension: 12-sp1
How to fix
Upgrade to a fixed version: Linux kernel 3.10.103, 3.12.62, 3.14.74, 3.16.37. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=93a2001bdfd5376c3dc2158653034c20392d15c5
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00044.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00048.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00049.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00050.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00051.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00052.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00053.html
- http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00054.html
Get alerted when CVE-2016-5829 or the next vulnerability affects your stack